Fixed: HxD: Opening multiple files sometimes not working

Bug reports concerning HxD.
Post Reply
lordcanty
Posts: 19
Joined: 23 Mar 2007 22:43

Fixed: HxD: Opening multiple files sometimes not working

Post by lordcanty » 11 Apr 2007 00:05

Hi,
sometimes when you try to open multiple files (by selecting them and right click -> Open with HxD or Open with Hxd read only) HxD will start opening them but then stop.
I haven't found how to trigger this consistently or what files are being excluded; if I retry to open them right after it happens HxD will usually open the rest of the files without problems. I think this happens more often when you have some of the files in the list already opened but it could be just my luck. I'll try to test it more but maybe this is a start?

Maël
Site Admin
Posts: 1148
Joined: 12 Mar 2005 14:15

Post by Maël » 11 Apr 2007 13:23

You are right, I could reproduce this behavior.

It apparently happens only if HxD wasn't opened before (and multiple instances-option is disabled). Do you see the same?

lordcanty
Posts: 19
Joined: 23 Mar 2007 22:43

Post by lordcanty » 11 Apr 2007 21:45

Well, I tried a couple of times and it worked how you described (HxD not opened). However I did the same with other files and then with the first files I used and it actually worked fine, weird. Maybe it has to do with the order I select files in Windows or something? It's not a big deal though.

When it stops one window starts flashing like it was already opened, I was probably mistaking this with an already opened file.

Maël
Site Admin
Posts: 1148
Joined: 12 Mar 2005 14:15

Post by Maël » 12 Apr 2007 14:44

You mean the tab flashes? This should only happen if the file was already opened once.

Could you please test the following version (it is in German, but you only need to test opening per context menu):
http://mh-nexus.de/downloads/HxDdev.exe

You need just to temporarily replace your actual version of HxD with this test-version and see if it opens the files as you expect it.

lordcanty
Posts: 19
Joined: 23 Mar 2007 22:43

Post by lordcanty » 15 Apr 2007 10:34

Yes, I meant when it stops loading multiple files one tab starts flashing like it was already opened, even if it wasn't (I think--not sure if this happens always).

I've tried the new beta a few times and so far it hasn't happened again. However since it works somewhat random for me I'll keep testing just in case.

Maël
Site Admin
Posts: 1148
Joined: 12 Mar 2005 14:15

Post by Maël » 15 Apr 2007 12:15

Okay, thanks.

lordcanty
Posts: 19
Joined: 23 Mar 2007 22:43

Post by lordcanty » 21 Apr 2007 02:12

I did a few more tests and so far it's working fine. I also got this situation where I had 4 files selected: opening them with the normal version would always stop after the second or third, but the the dev beta would open them correctly. I did this a few times changing back and forth versions to be sure.

I guess it's safe to say it's fixed. Thanks!

Maël
Site Admin
Posts: 1148
Joined: 12 Mar 2005 14:15

Post by Maël » 08 Jun 2007 23:42

Fixed in version 1.7.1 beta

Post Reply