Page 1 of 2

Fixed: Empty Editor window?

Posted: 26 Jan 2014 20:08
by gardnerjr
I'm having a strange issue when i open anything: the editor window is blank!


one time i opened it in read only and it worked, but once i found the field i wanted to change (from here: i realized it was in read-only.

every time i've opened it since, the window is blank, and when i open the disk it "dings" but no messagebox or anything shows up. it happens if i open up disks, files, pretty much anything. every once in a while it will work, though.

but if i do things like find, it appears that the data is there (if you look at the status bar of the empty window, it says Offset: 1c0 block 1c0-1c2 like it found the data i was looking for.

This is on a surface pro 2 on win81, if that makes any difference. maybe it has something to do with high dpi support? or monitors with different dpi / scaling?

Re: Empty Editor window?

Posted: 27 Jan 2014 15:13
by Maël
Or maybe related to Windows 8.1.

Thanks for reporting.

Re: Empty Editor window?

Posted: 29 Jan 2014 17:18
by rupello
I have the same problem on Windows 7(x64)

Re: Empty Editor window?

Posted: 29 Jan 2014 22:26
by Maël
Does it happen also with regular files, or just after failing to open hard disks? Any more details on when it happens?

As far as I can tell the dialog window that says it can't open the hard disk gets hidden in the background for some reason, so that's why you hear the ding sound but don't see the dialog window, and can't close the dialog window which is necessary for proper operation.

Subsequent operations are showing and empty window for this same reason because the dialog isn't closed yet.

Try running HxD as administrator.

Re: Empty Editor window?

Posted: 30 Jan 2014 19:49
by gardnerjr
it was happening all the time, even if i just open any random text file.

was running as admin since i wanted to edit a disk anyway.

today, when i went to repro it, it works just fine. :roll:

one thing i did change (but i have NO IDEA if it is related) is that i turned scaling down to 100%, applied to all displays, and have restarted a bunch of times since then, because some other apps/games are SUPER confused by the displays being at different scaling...

when i disconnect from the dock i'll try messing with scaling and docking and see if i can repro it again.

Re: Empty Editor window?

Posted: 01 Jul 2016 01:08
by Diegoisawesome
I'm having this exact same issue now, on a Surface Book with high DPI and Windows 10. I feel like I remember it working fine before but I may be mistaken.

Re: Empty Editor window?

Posted: 03 Jul 2016 08:26
by Maël
Does this occur randomly or is it reproducible? If so, could you describe the necessary steps?

Re: Empty Editor window?

Posted: 03 Aug 2016 20:27
by Diegoisawesome
Hi, sorry I took so long to respond. It happens every single time I open any file on my Surface Book. DPI is currently at 200%, 3000x2000 px display.

Re: Empty Editor window?

Posted: 06 Aug 2016 06:11
by Maël
I don't have a screen with such a high resolution handy. I tried to increase the DPI to 200%, but still couldn't reproduce it.

Does it also happen if you reduce the screen resolution and still keep a high DPI?

Re: Empty Editor window?

Posted: 06 Aug 2016 06:21
by Diegoisawesome
I just tried to replicate it again and for whatever reason, it's started working again before I even changed the resolution. If it shows up again, I'll try changing the resolution and seeing if that restores functionality.

Re: Empty Editor window?

Posted: 06 Aug 2016 09:57
by Diegoisawesome
It happened again and I was able to do some testing:

1. Changing screen resolution did not fix it.
2. I rebooted with the new resolution and that fixed it.
3. Reverting back to the old resolution didn't break it and I was able to close/reopen it many times without failure.

This is really odd...

Re: Empty Editor window?

Posted: 06 Aug 2016 14:00
by Maël
Maybe it depends on other programs being in the foreground.

You are using just one screen (of the surface book), no additional external screen?

Do you maybe use multiple desktops (the new Win10 feature) and switch between them?

Is there maybe some tilt function, that rotates the screen when you turn the surface book?

Does it usually happen directly after you start HxD and no file is open yet, or after HxD has been open for a while? Do you open a file through the menu/toolbar, or over the explorer context menu?

You are talking about the version, not the beta 2.0, right?

Re: Empty Editor window?

Posted: 06 Aug 2016 21:34
by Diegoisawesome
I'm only using one screen, yes. Not using multiple desktops. Also not tilting the Book but it does have a rotate function. The editor window that I'm referring to is the one that displays the actual bytes of a file so it happens directly after starting HxD and opening a file. As can be seen in the screenshot in the first post, the tab appears to show that the file is open but nothing else shows beneath it. I never use the Explorer context menu, only through the program once it's already opened. And it happens in both and beta 2.0.

Re: Empty Editor window?

Posted: 07 Aug 2016 03:22
by Maël
Ok, I fear this is some timing issue, maybe triggered by some shell extension, or some other programs running in the background, or random computer activity. This is going to be a pain to track down.

Please send me your HxD.ini after the problem occurred again.

A few more questions:
  • Do you run HxD as administrator, or doesn't it matter?
  • Does it happen with any file, or just files with special names or restricted rights?
  • Did you set the DPI compatibility settings in Windows Explorer's compatibility tab (under properties when you right click the HxD symbol) or not?
  • How did you open the file (the exact steps might matter)? Mouse, keyboard? What keyboard shortcut? Do you click the menu or use the keyboard, select the file by keyboard or mouse? Double click the file name in the open file window, or press the OK button in this window?
  • How do you open HxD? Double clicking its icon?

Re: Empty Editor window?

Posted: 07 Aug 2016 08:10
by Diegoisawesome
Okay so I figured out a way to reliably (99% of the time) cause the issue to happen. If I open the "Open file" dialog to choose a file, 99% of the time it will fail and give me a Windows error sound. However, if I choose the file from recent files, it'll open 100% of the time.
  • Running HxD as admin changes nothing.
  • It happens with any file, even if it's the same file as the one selected in the Recent Files menu.
  • Changing the DPI compatibility settings does not affect it.
  • Opening the file any way besides using the Recent Files menu will cause the issue.
  • Opening HxD in a different way does not affect it.
Also, a side note: when running these tests, I opened the file through the Open File dialog, got the issue, then opened it again (the tab flashed like it should to let me know that it's open), then closed the tab with middle-click on my mouse wheel, and suddenly it started spitting out a large amount of errors:!AmBaGhYdt-xhgYQv5dwHq-UATiSYag

Here's my HxD.ini, right after the issue occurs:!AmBaGhYdt-xhgYQwcIz24dyiAjZ3FA

Hope this helps!