Done: Allow Read-only access to files

Wishlists for new functionality and features.
Post Reply
bue
Posts: 1
Joined: 24 Feb 2012 22:37

Done: Allow Read-only access to files

Post by bue » 25 Feb 2012 00:01

I'm working with a file that is "being used by another process" according to HxD, however I only need to view the file in the editor and watch as the file updates itself. Every time I open the file it gives me this error:

Code: Select all

---------------------------
Error
---------------------------
Cannot open file "X:\abc.xxx" for read access. The process cannot access the file because it is being used by another process.
---------------------------
Retry   Cancel   
---------------------------
Other programs have no problem accessing the file, even when in use (e.g. Notepad++), and another hex editor (XVI32) gives a similar error but allowed for opening in Read-only. I can't even use the Read-only option in HxD's file open dialog for this. It would really be useful to be able to view the contents of this file when in use..

Also, another feature request: Live refreshing. HxD currently only updates when the window is in focus, but it would be useful for it to update constantly as the file is modified while in read-only.

Maël
Site Admin
Posts: 1127
Joined: 12 Mar 2005 14:15

Re: Allow Read-only access to files

Post by Maël » 25 Feb 2012 15:31

The read-access thing cannot be changed, this is due to large file support.

I'll check on the live-refresh.

Maël
Site Admin
Posts: 1127
Joined: 12 Mar 2005 14:15

Re: Allow Read-only access to files

Post by Maël » 06 Feb 2019 12:31

There have been several significant changes to reduce the locking required by HxD. Checkout version 2.0 and up.

It uses caching and minimal locking and a lot of parts were changed to allow to this feature.

When writing locking is still necessary, obviously, and during the short times data is read to ensure a consistent read.

This is the maximum relaxation of locking requirements that is possible and should handle most cases.

Post Reply